Pro Audio Support

Q:
Will Drumagog Platinum or Drumagog BFD work with BFD Lite?
 
A:
Unfortunately, in order to use the BFD features in Drumagog, the full version of BFD is required. This is due to the fact that the minimum requirement for BFD is v1.5.046.